summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2019-05-13 23:39:14 -0400
committerJean Lucas2019-05-13 23:39:14 -0400
commitb38f7b1ee6cf4b95694d5a49a92be57d2f3c1568 (patch)
treec213fa9e1fb307d73edb94df6710e486fe831a2c /PKGBUILD
parenta7851ee4fb25e667ad4317b9d973935dafd4aa84 (diff)
downloadaur-b38f7b1ee6cf4b95694d5a49a92be57d2f3c1568.tar.gz
Version bump to 1.1.4, require rust-nightly, add optdepends, dir typo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ff0921a896d..9093552812e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=hunter-holy
-pkgver=1.1.0
-pkgrel=2
+pkgver=1.1.4
+pkgrel=1
pkgdesc='ranger-like file browser written in Rust (holy branch)'
arch=(i686 x86_64)
url=https://github.com/rabite0/hunter
license=(WTFPL)
depends=(file)
-makedepends=(rust)
-optdepends=('ranger: to open files using rifle')
+makedepends=(rust-nightly)
+optdepends=('ranger: to open files using rifle'
+ 'xdg-open: fallback to open files with xdg-open')
provides=(hunter)
conflicts=(hunter hunter-git hunter-holy-git)
source=($url/archive/v$pkgver-holy.tar.gz)
-sha512sums=('8f9b907b062065b289b7481b0ff4a00fc58a533ca56261a9576801a4a22e225caacecce65780f4fd5a41f757fb3854e7452587e5b736c3946bec0100c7527616')
+sha512sums=('4540d4df98cd49a8171d62a090fbd5c83264784c710c89718bc7ae6559d205e14921c42136acaee9e7bd95121cbd2f5400c056dd663e5fa277f71572fdadd47a')
build() {
cd hunter-$pkgver-holy
- cargo build --release
+ cargo +nightly build --release
}
package() {
cd hunter-$pkgver-holy
install -D {target/release/hunter,extra/scope.sh} -t "$pkgdir"/usr/bin
- install -Dm 644 README.md -t "$pkgdir"/usr/share/hunter-holy
+ install -Dm 644 README.md -t "$pkgdir"/usr/share/hunter
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/hunter
}