summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2019-04-23 04:34:36 -0400
committerJean Lucas2019-04-23 04:34:36 -0400
commitfa68aaca235e7493f1377f987c3dfdd6366c477d (patch)
tree0adc34584a3018450d42ebc715d9a78940e6f8ea /PKGBUILD
downloadaur-fa68aaca235e7493f1377f987c3dfdd6366c477d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a2aeb197600
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=hunter-holy
+pkgver=1.0.10
+pkgrel=1
+pkgdesc='ranger-like file browser written in Rust (holy branch)'
+arch=(i686 x86_64)
+url=https://github.com/rabite0/hunter
+license=(WTFPL)
+depends=(file)
+makedepends=(rust)
+provides=(hunter)
+conflicts=(hunter hunter-git hunter-holy-git)
+source=($url/archive/v$pkgver-holy.tar.gz)
+sha512sums=('dd8d51651e882e711657fdc92e7068b6c5964fa4220ede09f2033b64b4b06a5063853a14a80585d1315ce34d5e04406649a50217e72f38647f451e22b81f724b')
+
+build() {
+ cd hunter-$pkgver-holy
+ cargo build --release
+}
+
+package() {
+ cd hunter-$pkgver-holy
+ install -D target/release/hunter -t "$pkgdir"/usr/bin
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/hunter
+}