summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormickybart2016-06-03 20:35:24 -0400
committermickybart2016-06-03 20:35:24 -0400
commit789d5a045bc72096570427337dbad46f15e391ed (patch)
tree1c2c8a287328624fbe412420426fa7d4c8e500eb /PKGBUILD
downloadaur-789d5a045bc72096570427337dbad46f15e391ed.tar.gz
initial: hybris-usb
rndis mode for Android USB (not a full tethering because the dhcp is not configured to provide a default route. For now this package provide a way to access the Android device) This package is (at least) used for the GNU/Linux for Android devices project: https://github.com/mickybart/gnulinux_support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb318a0b8689
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Michaƫl Serpieri <mickybart@pygoscelis.org>
+
+pkgname=hybris-usb
+pkgver=0.1
+pkgrel=2
+pkgdesc="USB control for Android with hybris"
+arch=('armv7h')
+url=""
+license=('custom')
+provides=()
+depends=('systemd' 'dhcp')
+options=()
+source=('usb-tethering'
+ 'usb-tethering.service'
+ 'dhcpd.conf'
+ 'dhcpd4.service-customexec.conf'
+ 'tmpfiles.d.hybris-usb.conf')
+md5sums=('2d270508c91e94997236e5dacd7bbc8d'
+ '7976b6c3d662802cc54e3458ec3b891e'
+ '8d25b1c3f1146635800db77f300b908c'
+ '0aff78dea49297c615946ee310c49a6b'
+ '91422a3f2a69c9800d25cd65358fe5df')
+
+build() {
+ cd "${srcdir}"
+
+}
+
+package() {
+ cd "${srcdir}"
+
+ # usb tethering
+
+ install -d ${pkgdir}/usr/bin
+ install -m 755 usb-tethering ${pkgdir}/usr/bin/
+
+ install -d ${pkgdir}/usr/lib/systemd/system/
+ install -m 644 usb-tethering.service ${pkgdir}/usr/lib/systemd/system/
+
+ # dhcpd configuration
+
+ install -d ${pkgdir}/usr/lib/tmpfiles.d/
+ install -m 644 tmpfiles.d.hybris-usb.conf ${pkgdir}/usr/lib/tmpfiles.d/hybris-usb.conf
+
+ install -d ${pkgdir}/etc/systemd/system/dhcpd4.service.d/
+ install -m 644 dhcpd4.service-customexec.conf ${pkgdir}/etc/systemd/system/dhcpd4.service.d/customexec.conf
+
+ install -d ${pkgdir}/etc/hybris-usb/
+ install -m 644 dhcpd.conf ${pkgdir}/etc/hybris-usb/
+}
+