summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScore_Under2022-01-07 08:11:47 +0000
committerScore_Under2022-01-07 08:11:47 +0000
commit2b5026272549f6dac6f68e97fd19dcc52d9eb191 (patch)
tree1cff345ffd32c3cc9bfca55d6a6df799b2874ffb /PKGBUILD
parent9e1d6a1db4ddadb837bca4db7607b2c3e25d78a1 (diff)
downloadaur-2b5026272549f6dac6f68e97fd19dcc52d9eb191.tar.gz
Update for v468, fix file writeable check
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f27f10bea34..20e9c22319e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus)
-pkgver=467
-pkgrel=2
+pkgver=468
+pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
license=(WTFPL)
@@ -24,13 +24,15 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
'python-pyqt5-chart: display bandwidth usage charts'
'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS')
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=c85507a2eefbd87a7700fb8c78fa365a92a83d7b"
+source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=fa5ebd9c22d2d2f05cab766240d39f99feb4be2b"
paths-in-opt.patch
+ fix-writeable-check.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
'6dde03b452b842d089cfdffb4cf8554b4985934d664054b2bb71006694f923c6'
+ 'a0eb88e96b4988f02e18afdb7fe8ba6b1b337e2a57ac899c19c761556071046e'
'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
@@ -38,6 +40,7 @@ sha256sums=('SKIP'
prepare() {
cd "$pkgbase"
git apply < ../paths-in-opt.patch
+ git apply < ../fix-writeable-check.patch
# Remove unit tests
rm -f "hydrus/Test"*.py