summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScore_Under2016-10-23 01:59:54 +0100
committerScore_Under2016-10-23 01:59:54 +0100
commit38f5c4873ec735842378afb46f2273d7b2aca850 (patch)
tree750701fee8db53e3791b11f190ef08f1fe983286 /PKGBUILD
parent44dec303cd9bd58b0ea121bfb5e5336ae740b24f (diff)
downloadaur-38f5c4873ec735842378afb46f2273d7b2aca850.tar.gz
Remove hydrus-sources package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 4 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 39427fb2d2a3..e76e259350a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,14 @@ options=(!strip) # Don't strip libs because there aren't any
DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
-pkgname=(hydrus hydrus-sources)
+pkgname=(hydrus)
pkgver=228
-pkgrel=2
+pkgrel=3
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
license=(WTFPL)
+install=hydrus.install
+conflicts=(hydrus-docs hydrus-sources)
url=http://hydrusnetwork.github.io/hydrus/
depends=(python2 wxpython opencv python2-beautifulsoup4 python2-yaml
hsaudiotag python2-pypdf2 python2-pafy python2-lz4 python2-numpy
@@ -52,18 +54,12 @@ build() {
}
package_hydrus() {
- install=hydrus.install
- conflicts=(hydrus-docs)
-
cd "$pkgbase"
# Create /opt/hydrus and copy hydrus files to there
install -m755 -d "${pkgdir}/opt/hydrus"
cp -r help include static client.pyw server.py "${pkgdir}/opt/hydrus/"
- # Remove .py files
- find "${pkgdir}/opt/hydrus/include" -name '*.py' -delete
-
# Create and populate /opt/hydrus/bin
install -d -m755 "${pkgdir}/opt/hydrus/bin"
ln -s /usr/bin/upnpc "${pkgdir}/opt/hydrus/bin/upnpc_linux"
@@ -82,18 +78,3 @@ package_hydrus() {
install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgbase}/"
install -m644 license.txt "${pkgdir}/usr/share/licenses/${pkgbase}/"
}
-
-package_hydrus-sources() {
- depends=()
- optdepends=('hydrus: The sources are not usable without extra files from the hydrus package')
- pkgdesc="Danbooru-like image tagging and searching system for the desktop (sources only)"
-
- cd "$pkgbase"
-
- # Create /opt/hydrus and copy hydrus sources to there
- install -m755 -d "${pkgdir}/opt/hydrus"
- cp -r include "${pkgdir}/opt/hydrus/"
-
- # Remove .pyo files
- find "${pkgdir}/opt/hydrus/include" -name '*.pyo' -delete
-}