summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScore_Under2016-10-23 01:52:39 +0100
committerScore_Under2016-10-23 01:52:39 +0100
commit44dec303cd9bd58b0ea121bfb5e5336ae740b24f (patch)
treebf031d1fe2db23a3821b4b683f13e850e1daa01a /PKGBUILD
parent9f4bc7a762f06316dbd8e8fde0cdc19cb589b255 (diff)
downloadaur-44dec303cd9bd58b0ea121bfb5e5336ae740b24f.tar.gz
Remove hydrus-docs package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 5 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80a2a6781808..39427fb2d2a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Score_Under <seejay 11@gmail com>
-options=(!strip docs) # Don't strip libs because there aren't any, don't strip docs because they're packaged separately
+options=(!strip) # Don't strip libs because there aren't any
DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
-pkgname=(hydrus hydrus-docs hydrus-sources)
+pkgname=(hydrus hydrus-sources)
pkgver=228
-pkgrel=1
+pkgrel=2
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
license=(WTFPL)
@@ -53,12 +53,13 @@ build() {
package_hydrus() {
install=hydrus.install
+ conflicts=(hydrus-docs)
cd "$pkgbase"
# Create /opt/hydrus and copy hydrus files to there
install -m755 -d "${pkgdir}/opt/hydrus"
- cp -r include static client.pyw server.py "${pkgdir}/opt/hydrus/"
+ cp -r help include static client.pyw server.py "${pkgdir}/opt/hydrus/"
# Remove .py files
find "${pkgdir}/opt/hydrus/include" -name '*.py' -delete
@@ -75,18 +76,6 @@ package_hydrus() {
# Install .desktop shortcut
install -d -m755 "${pkgdir}/usr/share/applications"
install -m644 ../hydrus.desktop "${pkgdir}/usr/share/applications/${pkgbase}.desktop"
-}
-
-package_hydrus-docs() {
- depends=()
- optdepends=()
- pkgdesc="Danbooru-like image tagging and searching system for the desktop (documentation)"
-
- cd "$pkgbase"
-
- # Create /opt/hydrus and copy hydrus help to there
- install -m755 -d "${pkgdir}/opt/hydrus"
- cp -r help "${pkgdir}/opt/hydrus/"
# Install license files
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgbase}"