summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScore_Under2024-04-13 14:45:41 +0100
committerScore_Under2024-04-13 14:45:41 +0100
commit5977925cfba7f8c6bfe57265b92ed366c7800e96 (patch)
tree8eeaeb85d41ffc10a82a3d077d0bc4fa6910ff5b /PKGBUILD
parent87e20537df0b76e8eed453a1ab283b85f3c3a00f (diff)
downloadaur-5977925cfba7f8c6bfe57265b92ed366c7800e96.tar.gz
Add dateparser to optdepends; rename hydrus desktop file
The latter of which fixes some icon issue some people had I guess?
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0af34bc3157..9960ecbe196f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ options=(!strip) # Don't strip libs because there aren't any
pkgname=hydrus
_pkgname=hydrus
pkgver=570
-pkgrel=1
+pkgrel=2
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
license=(custom)
@@ -27,6 +27,7 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'python-chardet: detect text encoding more accurately'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
'python-dateutil: improved fuzzy date search'
+ 'python-dateparser: date string to timestamp parser for predicate system'
'python-psd-tools: handle PSD files and extract thumbnails'
'python-pympler: debug menus to profile memory usage'
# 'python-pyqt6-charts: display bandwidth usage charts'
@@ -82,7 +83,7 @@ package() {
# Install .desktop shortcut
install -d -m755 "${pkgdir}/usr/share/applications"
- install -m644 ../hydrus.desktop "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -m644 ../hydrus.desktop "${pkgdir}/usr/share/applications/io.github.hydrusnetwork.hydrus.desktop"
# Install license files
install -d -m755 "${pkgdir}/usr/share/licenses/${_pkgname}"