summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScore_Under2022-03-02 23:37:11 +0000
committerScore_Under2022-03-02 23:37:11 +0000
commit7e091c688aac279def455fc4c274e3097aed4aa6 (patch)
tree9fd3c40a594ff7e77dd59a2ba9815b7220ee6a98 /PKGBUILD
parentedaf13fd85dfd18e7b9d7f92209c3fd24d04a801 (diff)
downloadaur-7e091c688aac279def455fc4c274e3097aed4aa6.tar.gz
Update for v475, add doc build step
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 031020819eb9..c37b1e7fc758 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus)
-pkgver=474
+pkgver=475
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -17,14 +17,14 @@ depends=(python python-opencv python-beautifulsoup4 python-yaml
python-pysocks python-psutil python-send2trash python-html5lib
python-requests python-qtpy emoji-font python-mpv
python-service-identity qt5-python-bindings fmt pyside2)
-makedepends=(git)
+makedepends=(git mkdocs mkdocs-material)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
'desktop-file-utils: to add Hydrus to your desktop environment menus'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
'python-pyqt5-chart: display bandwidth usage charts'
'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS')
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=83b2d2e6f128ceb00513400800a7aba95add99e8"
+source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=0f76d8a28cf1151358542c8f4655bbf1510b1429"
paths-in-opt.patch
hydrus-client
hydrus-server
@@ -49,6 +49,9 @@ build() {
msg 'Compiling .py files...'
python -OO -m compileall -fq .
+
+ msg 'Building documentation...'
+ mkdocs build -d help
}
package_hydrus() {