summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScore_Under2022-03-16 20:51:14 +0000
committerScore_Under2022-03-16 20:51:25 +0000
commite929be50bf4a4af4bb5b69ce3d8aca42625b2a83 (patch)
treedb69d4413d537864d5b86b8ff80536c452fce9c2 /PKGBUILD
parent8d19378354bc4ea58aaf9b22a246373495ef36c5 (diff)
downloadaur-e929be50bf4a4af4bb5b69ce3d8aca42625b2a83.tar.gz
Update for v477
Also restructure pkgbuild a little to bring it closer to hydrus-git where hydrus-git cannot be brought closer to this package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5e833432407..299e0442cac7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
options=(!strip) # Don't strip libs because there aren't any
DOC_DIRS=(opt/hydrus/help)
-pkgbase=hydrus
-pkgname=(hydrus)
-pkgver=476
+pkgname=hydrus
+_pkgname=hydrus
+pkgver=477
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -24,7 +24,7 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
'python-pyqt5-chart: display bandwidth usage charts'
'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS')
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=15fae4670f3d4c26868a81ceb48082ed79224c3e"
+source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=39f15229e46d642897962b04f4c8c7251625b573"
paths-in-opt.patch
hydrus-client
hydrus-server
@@ -36,7 +36,7 @@ sha256sums=('SKIP'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
prepare() {
- cd "$pkgbase"
+ cd "${srcdir}/${_pkgname}"
git apply < ../paths-in-opt.patch
# Remove unit tests
@@ -45,7 +45,7 @@ prepare() {
}
build() {
- cd "$pkgbase"
+ cd "${srcdir}/${_pkgname}"
msg 'Compiling .py files...'
python -OO -m compileall -fq .
@@ -54,8 +54,8 @@ build() {
mkdocs build -d help
}
-package_hydrus() {
- cd "$pkgbase"
+package() {
+ cd "${srcdir}/${_pkgname}"
# Create /opt/hydrus and copy hydrus files to there
install -m755 -d "${pkgdir}/opt/hydrus"
@@ -72,10 +72,10 @@ package_hydrus() {
# Install .desktop shortcut
install -d -m755 "${pkgdir}/usr/share/applications"
- install -m644 ../hydrus.desktop "${pkgdir}/usr/share/applications/${pkgbase}.desktop"
+ install -m644 ../hydrus.desktop "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
# Install license files
- install -d -m755 "${pkgdir}/usr/share/licenses/${pkgbase}"
- install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgbase}/"
- install -m644 license.txt "${pkgdir}/usr/share/licenses/${pkgbase}/"
+ install -d -m755 "${pkgdir}/usr/share/licenses/${_pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${_pkgname}/"
+ install -m644 license.txt "${pkgdir}/usr/share/licenses/${_pkgname}/"
}