summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2019-01-22 22:59:17 +0100
committerFrederic Bezies2019-01-22 22:59:17 +0100
commitaa9d168518726bcdfa93c139ce201f4ed9ff2f71 (patch)
tree821233214847a4d5366005504bea60376de93cea /PKGBUILD
parent51a7ac87b86946833573525ba70c62a7e19044f0 (diff)
downloadaur-aa9d168518726bcdfa93c139ce201f4ed9ff2f71.tar.gz
January 22nd, 2019 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 4 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61a61692a001..9576da8e0507 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: ahrs <Forward dot to at hotmail dot co dot uk>
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+#Contributor: ahrs <Forward dot to at hotmail dot co dot uk>
# Special thanks to the following people that provided the
# original PKGBUILD from hyper (https://aur.archlinux.org/packages/hyper/)
@@ -7,26 +8,17 @@
# Contributer: auk
pkgname=hyper-git
-pkgver=r958.3015855
+pkgver=3.0.0.canary.5.r0.g28282734
pkgrel=1
-epoch=
pkgdesc="A terminal built on web technologies"
arch=('any')
url="https://hyper.is/"
license=('MIT')
-groups=()
depends=('nodejs' 'electron' 'gconf')
makedepends=('git' 'npm' 'yarn' 'python2')
-checkdepends=()
-optdepends=()
-provides=()
-
conflicts=('hyperterm')
replaces=('hyperterm')
backup=()
-options=()
-install=
-changelog=
# You can set HYPER_BRANCH to master (or another branch) e.g
# export HYPER_BRANCH=master
@@ -44,11 +36,10 @@ noextract=()
md5sums=('SKIP'
'f3481e14cba331160339b3b5ab78872b'
'74cb7ba38e37332aa8300e4b6ba9c61c')
-validpgpkeys=()
pkgver() {
cd "${srcdir}/${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {