summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2015-11-01 22:31:08 -0500
committerChris Severance2015-11-01 22:31:08 -0500
commit32cd9b620bc70d3ddb4fecbd18d51162bd055bb6 (patch)
tree495f14c2e8d046dd4d5734c1d4299cde105abaa4 /PKGBUILD
downloadaur-32cd9b620bc70d3ddb4fecbd18d51162bd055bb6.tar.gz
Initial Import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..957cc3aada26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Simon Hollingshead <me at [firstnamelastname] dot com>
+
+set -u
+pkgname='hypercalc'
+pkgver='20150124'
+pkgrel='1'
+pkgdesc='A calculator designed to calculate extremely large numbers without overflowing.'
+arch=('any')
+url='http://mrob.com/pub/perl/hypercalc.html'
+license=('GPL')
+depends=('perl')
+source=("http://mrob.com/pub/comp/${pkgname}/${pkgname}.txt")
+sha256sums=('9db69045904a1c2f715b9e2ab78888fdcdf32d33b4cb4683511811edfb9fe89a')
+
+package() {
+ set -u
+ mkdir -p "${pkgdir}/usr/bin"
+ install -T "${srcdir}/${pkgname}.txt" "${pkgdir}/usr/bin/${pkgname}"
+ set +u
+}
+set +u