summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathon Fernyhough2016-11-04 21:09:45 +0000
committerJonathon Fernyhough2016-11-04 21:09:45 +0000
commit30577d8c738aa6d1f02cd52e3ebe7da6f8205e56 (patch)
tree16462c81aeb846e30939de4fe294ef6e83cc05ca /PKGBUILD
downloadaur-30577d8c738aa6d1f02cd52e3ebe7da6f8205e56.tar.gz
Initial PKGBUILD for 0.7.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d3724d59c57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jonathon Fernyhough <jonathon@manjaro.org>
+
+pkgname=hyperd
+pkgver=0.7.0
+pkgrel=0
+pkgdesc="Hypervisor-agnostic Docker Runtime"
+arch=('i686' 'x86_64')
+url="https://www.hypercontainer.io/"
+license=('Apache')
+depends=('libvirt')
+makedepends=('device-mapper' 'sqlite3' 'libvirt' 'go')
+optdepends=('hyperstart: boot files for hyperd instances')
+options=('!strip' '!emptydirs')
+source=("https://github.com/hyperhq/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('e79d4e6aebe01d2117e981050ecb88dd24f8a9e45e2fbe1a558bcd1ee5d90b88')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ # Needs to be able to find itself in $GOPATH
+ ln -s $(pwd) Godeps/_workspace/src/github.com/hyperhq/${pkgname}
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ install -D hyperctl "${pkgdir}/usr/bin/hyperctl"
+ install -D hyperd "${pkgdir}/usr/bin/hyperd"
+ install -D -m644 package/dist/etc/hyper/config "${pkgdir}/etc/hyper/config"
+ install -D -m644 package/dist/lib/systemd/system/hyperd.service "${pkgdir}/usr/lib/systemd/system/hyperd.service"
+}