summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThayne McCombs2015-09-20 18:07:41 -0600
committerThayne McCombs2015-09-20 18:07:41 -0600
commit1fcc2669a0e5dfd020712a733e56945adcaa5d33 (patch)
treeeef77040ee0615303b4b883012a8ad1583df9aaf /PKGBUILD
downloadaur-1fcc2669a0e5dfd020712a733e56945adcaa5d33.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03206a3b9720
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Thayne McCombs <bytecurry.software@gmail.com>
+pkgname=hyperfs
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A simple HTTP static file server"
+arch=('i386' 'x86_64')
+url="https://github.com/tmccombs/hyperfs"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('rust' 'cargo')
+provides=()
+source=("https://github.com/bytecurry/hyperfs/archive/v$pkgver.tar.gz")
+md5sums=('ae47cd66acf76c1b24c90acc50724a89')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D target/release/hyperfs "$pkgdir/usr/bin/hyperfs"
+ install -D LICENSE "$pkgdir/usr/share/licenses/hyperfs/LICENSE"
+}