summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2016-08-07 12:35:18 +0200
committerChristopher Reimer2016-08-07 12:35:18 +0200
commitb02dba545cf4307ba2022a292adc837bd061902d (patch)
tree200cbf133c7a3050f338b815399ae9584ecb8b29 /PKGBUILD
parent3daff700b5d19594398581e70bd6a748a9bb9bce (diff)
downloadaur-b02dba545cf4307ba2022a292adc837bd061902d.tar.gz
Use systemwide protobuf again.
Add missing protoc executable name.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a053823e38fa..a5c21f2f1b24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=hyperion
pkgver=1.03.2
-pkgrel=2
+pkgrel=3
pkgdesc="An opensource 'AmbiLight' implementation"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/hyperion-project/hyperion.ng"
license=('MIT')
-depends=('libusb' 'python' 'qt5-base')
+depends=('libusb' 'python' 'protobuf' 'qt5-base')
optdepends=('xorg-server: X11 grabbing')
makedepends=('avahi' 'cmake' 'git' 'qt5-serialport')
provides=('hyperion')
@@ -18,12 +18,6 @@ backup=('etc/hyperion/hyperion.config.json')
source=("https://github.com/tvdzwan/${pkgname}/archive/${pkgver}.tar.gz")
sha512sums=('7406f5bdf323d2799fb375557603fefd1f077cda287b5aa9ff10251b22d8dd07590458515b0e01ef97fba80885aab1aa72bd8b5d26873ad8ebcc1ba53d6776ec')
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}/dependencies/external"
- # Workaround: Arch's protobuf doesn't seem compatible
- git clone --depth 1 https://github.com/tvdzwan/protobuf.git
-}
-
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
mkdir -p build
@@ -32,6 +26,8 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DENABLE_QT5=ON \
-DUSE_SHARED_AVAHI_LIBS=ON \
+ -DUSE_SYSTEM_PROTO_LIBS=ON \
+ -DPROTOBUF_PROTOC_EXECUTABLE=/usr/bin/protoc \
..
make
}