summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicoHood2016-12-18 11:19:56 +0100
committerNicoHood2016-12-18 11:19:56 +0100
commit8ab991da6dad2301f9105ef0c8041a84aad357af (patch)
treec90e12edd41c0a2c178523239914e7a89eeb281b /PKGBUILD
parent9504a0ff0c01e4c14a75f89d1d38685a5b384775 (diff)
downloadaur-8ab991da6dad2301f9105ef0c8041a84aad357af.tar.gz
Updated build process equal to hyperion package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 34 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0007cd87ba34..3d65815076c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,54 @@
-# Maintainer: Robert Sprunk <archlinux@sprunk.me>
+# Maintainer: NicoHood <archlinux {cat} nicohood {dog} de>
+# PGP ID: 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
pkgname=hyperion-git
-pkgver=r680.c8a2fe8
+pkgver=r1117.6445c35
pkgrel=1
pkgdesc="An opensource 'AmbiLight' implementation"
-arch=('i686' 'x86_64')
-url="https://github.com/tvdzwan/hyperion"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://github.com/hyperion-project/hyperion"
license=('MIT')
-
-depends=('protobuf' 'libusb' 'qt4')
+depends=('libusb' 'protobuf' 'python' 'qt5-base')
optdepends=('xorg-server: X11 grabbing')
makedepends=('git' 'cmake')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-replaces=()
-backup=('etc/conf.d/hyperion.config.json')
-options=()
-source=('hyperion::git+https://github.com/tvdzwan/hyperion#branch=master'
- 'hyperiond.service')
-
-sha256sums=('SKIP'
- 'aab12fb3d901ea4c8694bd713b1a2187beae6a6ed40f3355d12fc7ad50aaf3fe')
-
-# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
-# a description of each element in the source array.
+provides=('hyperion')
+conflicts=('hyperion')
+backup=('etc/hyperion/hyperion.config.json')
+source=("${pkgname}::git+https://github.com/hyperion-project/hyperion")
+sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${srcdir}/${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/${pkgname%-git}"
- git submodule init
- git submodule update
- cmake -DENABLE_DISPMANX=OFF -DENABLE_SPIDEV=OFF -DENABLE_X11=ON
- make hyperiond hyperion-remote hyperion-v4l2 hyperion-x11
+ cd "${srcdir}/${pkgname}"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DENABLE_QT5=ON \
+ -DPLATFORM=x86 \
+ -DPROTOBUF_PROTOC_EXECUTABLE=/usr/bin/protoc \
+ -DUSE_SYSTEM_PROTO_LIBS=ON \
+ ..
+ make
}
package() {
- install -d "$pkgdir"/{usr/bin,etc/conf.d,usr/lib/systemd/system,opt/hyperion}
+ cd "${srcdir}/${pkgname}/build"
+ make install
+ cd ..
+
+ install -Dm 644 config/hyperion.config.json.example \
+ "${pkgdir}/etc/hyperion/hyperion.config.json"
- install -Dm755 "$srcdir/${pkgname%-git}/bin/hyperiond" "$pkgdir/usr/bin/hyperiond"
- install -Dm755 "$srcdir/${pkgname%-git}/bin/hyperion-remote" "$pkgdir/usr/bin/hyperion-remote"
- install -Dm755 "$srcdir/${pkgname%-git}/bin/hyperion-v4l2" "$pkgdir/usr/bin/hyperion-v4l2"
- install -Dm755 "$srcdir/${pkgname%-git}/bin/hyperion-x11" "$pkgdir/usr/bin/hyperion-x11"
-
- install -m 644 "$srcdir/${pkgname%-git}/config/hyperion_x86.config.json" "$pkgdir/etc/conf.d/hyperion.config.json"
+ install -Dm 644 bin/service/hyperion.systemd.sh \
+ "${pkgdir}/usr/lib/systemd/system/hyperiond.service"
- install -m 644 hyperiond.service "$pkgdir"/usr/lib/systemd/system/
+ rm -rf "${pkgdir}/usr/share/hyperion/service"
- cp -r "$srcdir/${pkgname%-git}/effects" "$pkgdir/opt/hyperion/"
+ install -Dm 644 LICENSE \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}