summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Houghton2021-02-08 23:36:12 -0500
committerJames Houghton2021-02-08 23:41:32 -0500
commitdb8eb7cabb00104c5bf8fc6ad3974dad85b31df0 (patch)
treed8c0945c35a55bc5f5cce8bc0aa84ac4dd0161e8 /PKGBUILD
downloadaur-db8eb7cabb00104c5bf8fc6ad3974dad85b31df0.tar.gz
Add initial PKGBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..797b24285e54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: James Houghton <jamesthoughton@gmail.com>
+
+pkgname=hypershare-git
+_pkgname=hypershare
+pkgver=b4dc27d
+pkgdesc="Small, interactive HTTP server with a TUI."
+pkgrel=1
+arch=('i686' 'x86_64')
+license=('BSD')
+makedepends=('cargo' 'git')
+source=("git+https://github.com/48ca/hypershare")
+url=https://github.com/48ca/hypershare
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${_pkgname}"
+ git rev-parse --short HEAD
+}
+
+build() {
+ cd "${_pkgname}"
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+package() {
+ cd "${_pkgname}"
+ install -Dm 755 target/release/${_pkgname} -t "${pkgdir}/usr/bin"
+}