summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjlaehne2020-08-06 14:12:55 +0200
committerjlaehne2020-08-06 14:12:55 +0200
commitda82992a7af006ca3829adc0846cad1f81c8c4d0 (patch)
tree4a2da5cad47dc6cb8c3d9265b5c3a6ddd3ce3806 /PKGBUILD
parent012f37631577fa9df0f532e6f805e241928ff906 (diff)
downloadaur-da82992a7af006ca3829adc0846cad1f81c8c4d0.tar.gz
Provides hyperspy 1.6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2afbe7841d0a..f230d45f26b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Tomas Ostasevicius <t dot ostasevicius at gmail dot com>
# Maintainer: Jonas Lähnemann <jonas at pdi-berlin dot de>
pkgname=hyperspy
-pkgver=1.5.2
+pkgver=1.6.0
pkgrel=1
pkgdesc="Hyperspectral data analysis"
arch=('any')
@@ -14,10 +14,13 @@ depends=('python' 'python-scipy' 'python-matplotlib' 'python-numpy'
'ipython-ipyparallel' 'python-dask' 'python-scikit-image'
'python-pint' 'python-statsmodels' 'python-numexpr' 'python-sparse'
'python-imageio' 'python-pyaml' 'python-ptable' 'python-tifffile'
- )
+ 'python-numba' )
-optdepends=('python-pillow: tiff export'
- 'python-seaborn: prettier plotting')
+optdepends=('python-scikit-learn: learning'
+ 'hyperspy-gui-ipywidgets: gui-jupyter'
+ 'hyperspy-gui-traitsui: gui-traitsui'
+ 'python-blosc: mrcz'
+ 'cython: speed' )
makedepends=('python-setuptools' )
@@ -25,7 +28,7 @@ provides=('hyperspy')
conflicts=('hyperspy')
source=(https://github.com/hyperspy/hyperspy/archive/v$pkgver.zip)
-sha256sums=('fd326d22be987038b2415d7886c39199569235d92aa2d6167c539a4dce125358')
+sha256sums=('942294a6a6f76ccb55c510ca07293ef93b3fe4eedd37b840b9c88366624b2026')
package() {
cd "$srcdir/$pkgname-$pkgver"