summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPetko Bordjukov2017-08-24 11:43:47 +0300
committerPetko Bordjukov2017-08-24 12:40:06 +0300
commitc3fb29c1ce6bf8082e1d3b5b7a2731a01ca27702 (patch)
tree49305c6cee0e269fb0b286c172c6bf12797f0642 /PKGBUILD
downloadaur-hyphen-bg-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd9065a63052
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Petko Bordjukov <bordjukov@gmail.com>
+
+_pkgname=hyphen-bg
+pkgname="$_pkgname"-git
+pkgver=r2331.93db4f5
+pkgrel=1
+pkgdesc="Bulgarian hyphenation rules"
+arch=(any)
+url="https://docs.libreoffice.org/lingucomponent.html"
+license=('GPL2')
+optdepends=('hyphen: offers hyphenation library functions')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=(dictionaries::git+https://github.com/LibreOffice/dictionaries.git)
+sha256sums=('SKIP')
+
+build() {
+ /bin/true
+}
+
+pkgver() {
+ cd "$srcdir"/dictionaries
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir"
+
+ # dictionary
+ install -dm755 "${pkgdir}"/usr/share/hyphen
+ cp -p dictionaries/bg_BG/hyph_bg_BG.dic "${pkgdir}"/usr/share/hyphen/
+
+ # symlink
+ install -dm755 "${pkgdir}"/usr/share/myspell/dicts
+ ln -s /usr/share/hyphen/hyph_bg_BG.dic "${pkgdir}"/usr/share/myspell/dicts/
+
+ # license
+ install -D -m644 "${srcdir}"/dictionaries/bg_BG/COPYING "${pkgdir}"/usr/share/licenses/"$pkgname"/LICENSE
+
+ # docs
+ install -dm755 "$pkgdir"/usr/share/doc/"$pkgname"
+ cp -p dictionaries/bg_BG/README_hyph_bg_BG.txt "$pkgdir"/usr/share/doc/"$pkgname"
+}