summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAskhat Bakarov2015-06-22 11:10:52 +0600
committerAskhat Bakarov2015-06-22 11:10:52 +0600
commit55f7f0d5894c0c68dea7a7d82802ab9458b7a0ad (patch)
tree3699ec3b9a01aba21f9e392e388f0006f34bb155 /PKGBUILD
downloadaur-55f7f0d5894c0c68dea7a7d82802ab9458b7a0ad.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e642f96c421
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id$
+
+pkgname=('hyphen-ru')
+pkgver=0.1
+pkgrel=2
+pkgdesc="Russian hyphenation rules"
+arch=(any)
+url="http://wiki.services.openoffice.org/wiki/Dictionaries"
+license=('LGPL')
+optdepends=('hyphen: offers hyphenation library functions')
+source=(#http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/dictionaries/hyph_ru_RU.zip
+# mirror from ApacheOpenOffice - see: http://www.openoffice.org/distribution/mirrors/master.html
+http://sunsite.informatik.rwth-aachen.de/ftp/pub/mirror/OpenOffice/contrib/dictionaries/hyph_ru_RU.zip)
+
+md5sums=('f8a8b8a368bc7394b5a4060082c44bb4')
+
+
+build() {
+ /bin/true
+}
+
+
+package() {
+
+ cd "$srcdir"
+ install -dm755 ${pkgdir}/usr/share/hyphen
+ #cp -p hyph_ru_RU.dic $pkgdir/usr/share/hyphen
+ install -m 644 hyph_ru_RU.dic $pkgdir/usr/share/hyphen
+
+ # the symlinks
+ install -dm755 ${pkgdir}/usr/share/myspell/dicts
+ pushd $pkgdir/usr/share/myspell/dicts
+ for file in $pkgdir/usr/share/hyphen/*; do
+ ln -sv /usr/share/hyphen/$(basename $file) .
+ done
+ popd
+
+ # docs
+ install -dm755 ${pkgdir}/usr/share/doc/$pkgname
+ install -m 644 README_hyph_ru_RU.txt $pkgdir/usr/share/doc/$pkgname
+}
+