summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFilip Markovic2022-12-10 03:59:16 +0100
committerFilip Markovic2022-12-10 03:59:16 +0100
commite144b814d2539fcae5b1f2134eb4d38f6cc8a629 (patch)
treef4ba5c952c6c5decab659fe7dff0cb9f13a17516 /PKGBUILD
downloadaur-e144b814d2539fcae5b1f2134eb4d38f6cc8a629.tar.gz
Init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ac9b0818425
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Filip Markovic <f12markovic at gmail dot com>
+_pkgname="hyprcwd"
+pkgname="$_pkgname-git"
+pkgver=1.d076b59
+pkgrel=1
+pkgdesc="xcwd for Hyprland"
+arch=(x86_64 aarch64)
+url="https://github.com/vilari-mickopf/$_pkgname"
+license=('MIT')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("${_pkgname}::git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make PREFIX="$pkgdir/usr" install
+}