summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMoetaYuko2024-04-15 09:58:35 +0800
committerMoetaYuko2024-04-15 09:58:35 +0800
commitc93e130f5fdb3d85d08ab555a428a6bccd88d447 (patch)
treeeac9cb8c256ddfb56bccd84b14ce3fdd3e3fd6c6 /PKGBUILD
parent84f2d3a92ffc439ecd685c51e1d4453512388cc0 (diff)
parentee9dd37fe92e8070e5f97e69a1efa5e517bdfe5c (diff)
downloadaur-c93e130f5fdb3d85d08ab555a428a6bccd88d447.tar.gz
Merge branch 'master' of https://aur.archlinux.org/hyprland-hidpi-xprop-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 247755e9a91b..7b4380b609e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname="hyprland"
pkgname="${_pkgname}-hidpi-xprop-xclip-git"
-pkgver=0.37.1.r20.05c84304
+pkgver=0.38.0.r105.582d6233
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
@@ -30,6 +30,7 @@ depends=(
polkit
glslang
libdisplay-info
+ libliftoff
libinput
libxcb
libxkbcommon
@@ -39,6 +40,7 @@ depends=(
xcb-util-errors
xcb-util-renderutil
xcb-util-wm
+ xcb-util-image
seatd
xorg-xwayland-hidpi-xprop
tomlplusplus
@@ -55,7 +57,7 @@ makedepends=(
xorgproto
)
source=("${_pkgname}::git+https://github.com/hyprwm/Hyprland.git"
- "git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
+ "git+https://github.com/hyprwm/wlroots-hyprland.git"
"git+https://github.com/hyprwm/hyprland-protocols.git"
"git+https://github.com/canihavesomecoffee/udis86.git"
"0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch"
@@ -82,15 +84,15 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- rm -rf subprojects/wlroots subprojects/hyprland-protocols
+ rm -rf subprojects/wlroots-hyprland subprojects/hyprland-protocols
git submodule init
- git config submodule.wlroots.url "${srcdir}"/wlroots
+ git config submodule.subprojects/wlroots-hyprland.url "${srcdir}"/wlroots-hyprland
git config submodule.subprojects/hyprland-protocols.url "${srcdir}"/hyprland-protocols
git config submodule.subprojects/udis86.url "${srcdir}"/udis86
- git -c protocol.file.allow=always submodule update subprojects/wlroots
+ git -c protocol.file.allow=always submodule update subprojects/wlroots-hyprland
git -c protocol.file.allow=always submodule update subprojects/hyprland-protocols
git -c protocol.file.allow=always submodule update subprojects/udis86
- cd subprojects/wlroots
+ cd subprojects/wlroots-hyprland
patch -Np1 -i "${srcdir}"/0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch
patch -Np1 -i "${srcdir}"/0001-xwayland-support-HiDPI-scale.patch
patch -Np1 -i "${srcdir}"/0002-Fix-configure_notify-event.patch
@@ -107,7 +109,7 @@ build() {
package() {
cd "${srcdir}/${_pkgname}"
- meson install -C subprojects/wlroots/build --destdir "${pkgdir}/tmpwlr"
+ meson install -C subprojects/wlroots-hyprland/build --destdir "${pkgdir}/tmpwlr"
install -Dm755 build/Hyprland -t "${pkgdir}/usr/bin"
pushd "${pkgdir}/usr/bin" && ln -sf Hyprland hyprland && popd
install -Dm755 build/hyprctl/hyprctl -t "${pkgdir}/usr/bin"
@@ -116,14 +118,13 @@ package() {
install -Dm644 example/hyprland.desktop -t "${pkgdir}/usr/share/wayland-sessions"
install -Dm644 example/hyprland.conf -t "${pkgdir}/usr/share/hyprland"
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm644 subprojects/wlroots/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-wlroots"
+ install -Dm644 subprojects/wlroots-hyprland/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-wlroots-hyprland"
install -Dm644 subprojects/udis86/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-udis86"
install -Dm644 docs/*.1 -t "${pkgdir}/usr/share/man/man1"
- install -Dm755 ${pkgdir}/tmpwlr/usr/local/lib/libwlroots.so.* -t "${pkgdir}/usr/lib"
install -d "${pkgdir}/usr/include/hyprland/protocols"
- install -d "${pkgdir}/usr/include/hyprland/wlroots"
+ install -d "${pkgdir}/usr/include/hyprland/wlroots-hyprland"
cp -R src ${pkgdir}/usr/include/hyprland/
- cp -R ${pkgdir}/tmpwlr/usr/local/include/* ${pkgdir}/usr/include/hyprland/wlroots/
+ cp -R ${pkgdir}/tmpwlr/usr/local/include/* ${pkgdir}/usr/include/hyprland/wlroots-hyprland/
find ${pkgdir}/usr/include/hyprland/ -type f ! -name '*.h*' -delete
rm -rf ${pkgdir}/tmpwlr
cp protocols/*-protocol.h ${pkgdir}/usr/include/hyprland/protocols