summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMoetaYuko2023-10-24 10:56:33 +0800
committerMoetaYuko2023-10-24 10:56:55 +0800
commiteb3bfec2edca9d0160d0421c073b6790831dd7b9 (patch)
tree979d43e80fa5155a6f8e326de07a34897438c964 /PKGBUILD
parent896a977476aa74fcdbbdc44225948295a08e31a8 (diff)
downloadaur-eb3bfec2edca9d0160d0421c073b6790831dd7b9.tar.gz
Add xclip patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08b31d3c7253..a0b8bb4e4ec3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Aleksana QwQ <me@aleksana.moe>
-# Maintainer: q234 rty <q23456yuiop at gmail dot com>
+# Maintainer: MoetaYuko <loli at yuko dot moe>
+# Contributor: Aleksana QwQ <me@aleksana.moe>
+# Contributor: q234 rty <q23456yuiop at gmail dot com>
# Contributor: ThatOneCalculator <kainoa@t1c.dev>
# Contributor: lilydjwg <lilydjwg@gmail.com>
# Contributor: FabioLolix
_pkgname="hyprland"
-pkgname="${_pkgname}-hidpi-xprop-git"
+pkgname="${_pkgname}-hidpi-xprop-xclip-git"
pkgver=0.30.0.r91.261c5944
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
@@ -56,7 +57,8 @@ source=("${_pkgname}::git+https://github.com/hyprwm/Hyprland.git"
"git+https://github.com/canihavesomecoffee/udis86.git"
"0001-xwayland-support-HiDPI-scale.patch"
"0002-Fix-configure_notify-event.patch"
- "0003-Fix-size-hints-under-Xwayland-scaling.patch")
+ "0003-Fix-size-hints-under-Xwayland-scaling.patch"
+ "https://gitlab.freedesktop.org/wlroots/wlroots/-/merge_requests/4359.patch")
conflicts=("${_pkgname}")
provides=("${_pkgname}=${pkgver}")
sha256sums=('SKIP'
@@ -65,7 +67,8 @@ sha256sums=('SKIP'
'SKIP'
'2fd861a76fb7a6b0bba12e7d307ad655e40ec93a84c88dfc00571aac6e119e85'
'1314d0ee63a4249698791d86cce5e6cdb4f005b81bbb1c6a747578d2a9223795'
- 'c08dd62a1786eeb7506f1839bfcbba791502360392c929e620244f70c8ca5b61')
+ 'c08dd62a1786eeb7506f1839bfcbba791502360392c929e620244f70c8ca5b61'
+ '3604daecd1db061c0ded213db17eaf9f87fc276e4540fed6ef9d68b7119f3603')
options=(debug)
pkgver() {
@@ -88,6 +91,7 @@ prepare() {
patch -Np1 -i "${srcdir}"/0001-xwayland-support-HiDPI-scale.patch
patch -Np1 -i "${srcdir}"/0002-Fix-configure_notify-event.patch
patch -Np1 -i "${srcdir}"/0003-Fix-size-hints-under-Xwayland-scaling.patch
+ patch -Np1 -i "${srcdir}"/4359.patch
}
build() {