summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzjeffer2023-11-06 23:42:46 +0100
committerzjeffer2023-11-06 23:42:46 +0100
commite8c3fa38deb3303417bfaec8081f5d018823bc91 (patch)
tree70118bb85d7daae19ec84dcc47f124e6ef880cd2 /PKGBUILD
parentec2e6affe650e83efb6ae04de5231441593b7872 (diff)
downloadaur-e8c3fa38deb3303417bfaec8081f5d018823bc91.tar.gz
Fixed package() not installing all headers, fixes plugin compilation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa7030a42217..8343685ee6e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Kuan-Yen Chou <kuanyenchou@gmail.com>
pkgname=hyprland-nvidia-git
-pkgver=0.30.0.r95.8af3e7bee
+pkgver=0.31.0.r105.g29e0a711
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA patch)"
arch=(any)
@@ -98,7 +98,7 @@ build() {
package() {
# Install hyprland headers
cd "$srcdir/$pkgname"
- find src -name '*.hpp' -exec install -Dm644 {} "$pkgdir/usr/include/hyprland/{}" \;
+ find src -name '*.h*' -exec install -Dm644 {} "$pkgdir/usr/include/hyprland/{}" \;
# Fix $srcdir reference
sed -i -e "/ICONDIR/ s,$srcdir/tmpwlr,/usr," "$srcdir/$pkgname/subprojects/wlroots/build/include/config.h"