summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCallum Wishart2023-10-16 18:45:20 +1000
committerCallum Wishart2023-10-16 18:45:20 +1000
commitec2e6affe650e83efb6ae04de5231441593b7872 (patch)
tree261d0347f6577cd86852a05c95b62843d0cd7fea /PKGBUILD
parent65db221271563b58d6ae3e37b6725955adfdbf03 (diff)
downloadaur-ec2e6affe650e83efb6ae04de5231441593b7872.tar.gz
patched for new hyprland cmake (thanks, salimp)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25dc9573bbf2..fa7030a42217 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Kuan-Yen Chou <kuanyenchou@gmail.com>
pkgname=hyprland-nvidia-git
-pkgver=0.27.2.r62.g08651736
+pkgver=0.30.0.r95.8af3e7bee
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA patch)"
arch=(any)
@@ -69,7 +69,8 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
git submodule update --init
- make fixwlr
+ sed -E -i -e 's/(soversion = 12)([^032]|$$)/soversion = 12032/g' ./subprojects/wlroots/meson.build
+ rm -rf ./subprojects/wlroots/build
sed -i -e '/^release:/{n;s/-D/-DCMAKE_SKIP_RPATH=ON -D/}' Makefile
cd "$srcdir/$pkgname/subprojects/wlroots"
patch -Np1 < "$srcdir/$pkgname/nix/patches/wlroots-nvidia.patch"
@@ -90,8 +91,7 @@ build() {
# Build hyprland
cd "$srcdir/$pkgname"
- make protocols
- make release
+ make all
make -C hyprctl all
}