summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorskydrome2020-02-29 03:38:18 -0500
committerskydrome2020-02-29 03:38:18 -0500
commitcfed2df18e505601fe5256d7b85dbe180cd56f2f (patch)
tree5c361bb38bedea6af7a872619ab0eb853ba58919 /PKGBUILD
parent328a5b16611e0290523fd4e84a69bc91be5a8bfa (diff)
downloadaur-cfed2df18e505601fe5256d7b85dbe180cd56f2f.tar.gz
add upstream fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c18c5894269..c4e0092a3ece 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=i2p
pkgver=0.9.45
-pkgrel=1
+pkgrel=2
pkgdesc="A distributed anonymous network"
url="https://geti2p.net"
license=('GPL2')
@@ -28,10 +28,11 @@ _url="https://launchpad.net/i2p/trunk/${pkgver}/+download"
source=("${_url}/i2psource_${pkgver}.tar.bz2"{,.sig}
"modern-dark.zip::https://github.com/eyedeekay/modern-dark/archive/master.zip"
+ # use in .46 if it hasnt been updated by then
#"https://download.db-ip.com/free/dbip-country-lite-$(date +%Y-%m).mmdb.gz"
'i2prouter.service' 'i2p.tmpfiles' 'wrapper.config' 'router.config'
'i2prouter.bash' 'i2prouter.sh' 'chromium-i2p.sh'
- #upstream.patch::'https://github.com/i2p/i2p.i2p/compare/f2f29d6...cad3c46.patch'
+ upstream.patch::'https://github.com/i2p/i2p.i2p/commit/0bec84a.patch'
)
sha256sums=('e65c7dbbf464b6bc64afb228306fbfed0f1e67ffec74f96852b82acade53921c'
@@ -44,11 +45,12 @@ sha256sums=('e65c7dbbf464b6bc64afb228306fbfed0f1e67ffec74f96852b82acade53921c'
'90f202e5b66d5a5b425522b409e71fb892d34c534e32ce2d6fe5284015cacf94'
'7a19b9f90c8792460fd58e8b8aa435a065e34d29a942479850472510e9d3078a'
'8d39f080c7a2e49226db3a785f3e18583159ef2f95e1ab467fd9984c4e38c9f5'
- '77e359cf880ccc09f504372ef85c8ad3ab7d1186106a4ae92c4ff4f37ae650e0')
+ '77e359cf880ccc09f504372ef85c8ad3ab7d1186106a4ae92c4ff4f37ae650e0'
+ '8456fea20259c8e3c8259078ff713725ac58fb6b83c37ce612f9e5737279082d')
prepare() {
cd "$pkgname-$pkgver"
- #patch -Np1 -i ../upstream.patch
+ patch -Np1 -i ../upstream.patch
#cp -f ../dbip-country-lite-$(date +%Y-%m).mmdb.gz installer/resources/GeoLite2-Country.mmdb.gz
}