summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302018-05-17 16:03:56 +0200
committerM0Rf302018-05-17 16:03:56 +0200
commit97b8345389f4d7ca4f2131936294575d13eacde7 (patch)
treeb4a8d2d9a9cc46f1db5ab552c28f05fa50234457 /PKGBUILD
parent64b8b766d7a70b4b092cc2e371345726b3eabff9 (diff)
downloadaur-97b8345389f4d7ca4f2131936294575d13eacde7.tar.gz
i2pd: fixed GCC 8 compilation (thanks to post-factum)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ca158ee8379..ce698a14baa4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,21 @@
# Contributor: redfish
# Contributor: atommixz
# Contributor: denn
+# Contributor: post-factum
pkgname=i2pd
pkgver=2.18.0
-pkgrel=1
+pkgrel=2
pkgdesc="Simplified C++ implementation of I2P client"
arch=('i686' 'x86_64' 'armv7h')
url="https://github.com/PurpleI2P/$pkgname"
license=('BSD')
depends=('boost-libs' 'miniupnpc' 'openssl' 'zlib')
makedepends=('boost' 'cmake')
-source=(https://github.com/PurpleI2P/${pkgname}/archive/${pkgver}.tar.gz)
+source=(https://github.com/PurpleI2P/${pkgname}/archive/${pkgver}.tar.gz
+ https://github.com/PurpleI2P/i2pd/commit/4af0caa50639c9c080034b2ea8239eb7e06f0ba3.patch
+ https://github.com/PurpleI2P/i2pd/commit/21c35f770b26ebf00f94365769bab74753fa06d1.patch
+)
install=$pkgname.install
backup=(etc/$pkgname/$pkgname.conf
etc/$pkgname/tunnels.conf)
@@ -21,6 +25,11 @@ conflicts=("$pkgname-git")
build() {
cd $srcdir/$pkgname-$pkgver
+
+ # GCC 8 fixes
+ patch -Np1 -i ../21c35f770b26ebf00f94365769bab74753fa06d1.patch
+ patch -Np1 -i ../4af0caa50639c9c080034b2ea8239eb7e06f0ba3.patch
+
cd build
cmake . -DCMAKE_CXX_FLAGS="-w" \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -71,4 +80,6 @@ package(){
chmod -R o= $pkgdir/${_home_dest}
}
-md5sums=('02a8aaa11d97d7ebd1bf600acba1cf1b')
+md5sums=('02a8aaa11d97d7ebd1bf600acba1cf1b'
+ 'c1755b808a6a2fc528172523c2f02a68'
+ '3d39e1a51bb13d05696ccaac36afeb9e')