summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpando8552024-05-09 19:28:19 +0000
committerpando8552024-05-09 19:28:19 +0000
commitd5d296cb5a703ae5698016ce21e94ff9ff080b25 (patch)
tree2e080d705ee7e6ace70cddfcd3739aed15656726 /PKGBUILD
downloadaur-d5d296cb5a703ae5698016ce21e94ff9ff080b25.tar.gz
Update AUR package to version 0.3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28e6447bbc3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Pando85 <pando855@gmail.com>
+
+pkgname=i3-auto-layout
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Automatic, optimal tiling for i3wm "
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/pando85/i3-auto-layout"
+license=('GPL')
+depends=('i3-wm')
+makedepends=('cargo'
+ 'git')
+source=("git+$url.git#tag=v${pkgver}?signed")
+validpgpkeys=('C15CDDF9318F14398300B917C6CB8A1793CA3F94')
+sha512sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/i3-auto-layout"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$srcdir/i3-auto-layout"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+package() {
+ cd "$srcdir/i3-auto-layout"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/i3-auto-layout"
+}