summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIngo Bürk2020-11-15 17:22:21 +0100
committerIngo Bürk2020-11-15 17:22:21 +0100
commit023bf7b668ee40dfa6c752aefe5239d3de528bda (patch)
tree586094e8084bb4e00621a4eca7705bc28111eb79 /PKGBUILD
parent51d12a797e5b01ceb3a57013bab165385d053b1b (diff)
downloadaur-023bf7b668ee40dfa6c752aefe5239d3de528bda.tar.gz
Update for meson
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 9 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dccd48046df8..c9c79958c028 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# This PKGBUILD was prepared for pacman 4.1 by William. Thank you. :-)
pkgname=i3-git
-pkgver=4.18.r368.g83078a1e
+pkgver=4.18.r395.g93d3f9cc
pkgrel=1
pkgdesc='An improved dynamic tiling window manager'
arch=('i686' 'x86_64')
@@ -16,15 +16,15 @@ conflicts=('i3-wm' 'i3bar' 'i3bar-git')
groups=('i3-vcs')
depends=(xcb-util-cursor xcb-util-keysyms xcb-util-wm xcb-util-xrm libev yajl startup-notification
pango libxkbcommon-x11)
-makedepends=(asciidoc xmlto)
+makedepends=(git asciidoc docbook-xsl xmlto perl pkgconfig meson)
optdepends=('dmenu: As menu.'
'i3lock: For locking your screen.'
'i3status: To display system information with a bar.'
'perl: i3-save-tree and i3-dmenu-desktop'
'perl-anyevent-i3: Features like saving the layout.'
'perl-json-xs: Features like saving the layout.')
-options=('docs' '!strip' 'debug')
-source=('git://github.com/i3/i3')
+options=('docs' '!strip')
+source=('git://github.com/i3/i3#branch=next')
sha1sums=('SKIP')
_gitname='i3'
@@ -35,30 +35,21 @@ pkgver() {
}
-prepare() {
- cd "$_gitname"
-
- autoreconf -fvi
-}
-
build() {
cd "$_gitname"
rm -rf build
mkdir -p build && cd build
- ../configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --disable-sanitizers
-
- make
+ arch-meson ..
+ meson compile
}
package() {
- cd "$_gitname/build"
+ cd "$_gitname"
+ cd build/
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir/" meson install
install -Dm644 ../LICENSE \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"