summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Niklaus2015-08-15 16:44:14 +0200
committerPatrick Niklaus2015-08-15 16:49:54 +0200
commit70bd20562be635f9d106471ee0f1fcbaaa676877 (patch)
treeb8eb0bc8f72779a3e88200a0b7ab4f81cefbb16b /PKGBUILD
downloadaur-70bd20562be635f9d106471ee0f1fcbaaa676877.tar.gz
First version of i3-gnome
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05642a357982
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Patrick Niklaus <patrick.niklaus@student.kit.edu>
+pkgname=i3-gnome
+pkgver=5.0
+pkgrel=1
+pkgdesc="Starts i3 inside a gnome session."
+arch=('any')
+url="https://github.com/TheMarex/i3-gnome"
+license=('MIT')
+groups=()
+depends=()
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(i3-gnome-5.0.zip::https://github.com/TheMarex/i3-gnome/archive/5.0.zip)
+noextract=()
+md5sums=('8427a7d55af3071c8194bcef6cd842e9')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}