summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarl Schwan2019-05-11 12:34:27 +0200
committerCarl Schwan2019-05-11 12:39:47 +0200
commit6814159cad77312dd72714ae8b886628fb572697 (patch)
tree0935476eaaacf67319eeb3888306cf426bd98c4e /PKGBUILD
downloadaur-6814159cad77312dd72714ae8b886628fb572697.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00f96d238750
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Carl Schwan <carl at carlschwan dot eu>
+
+pkgname=i3-plasma
+_pkgsourcename=i3-plasma
+pkgver=4.16.1
+pkgrel=1
+pkgdesc='A fork of i3-gaps tiling window manager with default configuration for plasma'
+arch=('i686' 'x86_64')
+url='https://github.com/Airblader/i3'
+license=('GPL-3.0')
+provides=('i3-wm' 'kwin')
+conflicts=('i3-wm' 'i3-gaps')
+groups=('i3')
+depends=('xcb-util-keysyms' 'xcb-util-wm' 'libev' 'yajl'
+ 'startup-notification' 'pango' 'perl' 'xcb-util-cursor' 'xcb-util-xrm'
+ 'libxkbcommon-x11' 'plasma-desktop' 'wmctrl')
+makedepends=('bison' 'flex' 'asciidoc' 'xmlto')
+optdepends=('konsole: The terminal emulator used in the default config.'
+ 'perl-json-xs: For i3-save-tree'
+ 'perl-anyevent-i3: For i3-save-tree')
+backup=(etc/i3/config)
+options=('docs' '!strip')
+source=('git+https://gitlab.com/ognarb/i3-kde.git')
+sha256sums=('SKIP')
+
+prepare(){
+ mkdir -p build
+ cd "${_pkgsourcename}-${pkgver}"
+
+ autoreconf -fvi
+}
+
+build() {
+ cd build
+
+ ../i3-$pkgver/configure \
+ --prefix=/usr \
+ --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd build
+
+ make DESTDIR="${pkgdir}/" install
+ install -Dt "$pkgdir/usr/share/man/man1" -m644 man/*.1
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 ../i3-$pkgver/LICENSE
+}
+
+# vim:set ts=2 sw=2 et:
+