summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Simatic2020-12-19 15:17:31 +0100
committerThomas Simatic2020-12-19 15:17:31 +0100
commit76050dca77c9f83d67958a66faa5e7e9c5419a96 (patch)
tree894b1e168462b32305dab5aa35e22989928eac4b /PKGBUILD
parent758a66b3a5aa233c67049752ce82e19b40c1ae2a (diff)
downloadaur-76050dca77c9f83d67958a66faa5e7e9c5419a96.tar.gz
now use git tag for package versions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 204bf87c87dc..3a20dc4e9bbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Thomas Simatic <thomas.sim@mailo.com>
pkgname="i3-scratchpad-git"
-pkgver=9
-pkgrel=2
+pkgver=1.1
+pkgrel=3
pkgdesc="The Swiss Army Knife of floating i3 windows"
arch=(any)
license=('Unlicense')
-depends=(i3-wm wmctrl bash)
+depends=(i3-wm wmctrl bash xdotool)
optdepends=('rxvt-unicode: for terminal programs support')
source=("git+https://gitlab.com/aquator/i3-scratchpad.git")
@@ -13,7 +13,7 @@ md5sums=(SKIP)
pkgver() {
cd ${pkgname%-git}
- git rev-list --all --count
+ git describe --tags | sed "s+-+.r+" | tr - .
}
package() {