summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Simatic2020-11-27 14:35:07 +0100
committerThomas Simatic2020-11-27 14:35:07 +0100
commitbd90a95573f294b79bf28c405fa6ee5812074972 (patch)
treedff08149ba6e0fb241b644497c5ecedd69ca5a27 /PKGBUILD
downloadaur-bd90a95573f294b79bf28c405fa6ee5812074972.tar.gz
i3-scratchpad pkgbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2c443ab8648
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Thomas Simatic <thomas.sim@mailo.com>
+pkgname="i3-scratchpad-git"
+pkgver=7
+pkgrel=1
+pkgdesc="The Swiss Army Knife of floating i3 windows"
+arch=(any)
+license=('Unlicense')
+depends=(i3-wm bash)
+optdepends=('rxvt-unicode: for terminal programs support')
+
+source=("git+https://gitlab.com/aquator/i3-scratchpad.git")
+md5sums=(SKIP)
+
+pkgver() {
+ cd ${pkgname%-git}
+ git rev-list --all --count
+}
+
+package() {
+ cd ${pkgname%-git}
+ install -Dm 755 i3-scratchpad -t "$pkgdir"/usr/bin
+}