summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwheatdog2019-03-14 19:05:29 +0800
committerwheatdog2019-03-14 19:05:29 +0800
commit2635d98fb576fe4f79267b79b86a9ee822b1dc20 (patch)
treef7f0ac0e1d067022b9afec3029fa8d9f0ae1ff37 /PKGBUILD
downloadaur-2635d98fb576fe4f79267b79b86a9ee822b1dc20.tar.gz
Initial upload: i3-workspace-groups-git r78.e30c30f-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31fcfa946774
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Tim Liou <wheatdoge at gmail dot com>
+_pkgname="i3-workspace-groups"
+pkgname="${_pkgname}-git"
+pkgver=r78.e30c30f
+pkgrel=1
+pkgdesc='Manage i3wm workspaces in groups you control'
+url='https://github.com/infokiller/i3-workspace-groups'
+arch=('any')
+license=('MIT')
+source=("git+https://github.com/infokiller/i3-workspace-groups")
+sha256sums=('SKIP')
+depends=('python' 'i3-wm')
+makedepends=('python-setuptools' 'git')
+provides=('i3-workspace-groups')
+conflicts=('i3-workspace-groups')
+install="${pkgname}.install"
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}