summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlessandro Cerruti2023-05-26 00:51:09 +0200
committerAlessandro Cerruti2023-05-26 00:51:09 +0200
commit34854fc7fd6119e44064b9ef9152f308e5506525 (patch)
tree371e712d3311af1efa42224bc5689faf6cfb2bec /PKGBUILD
parente8364ecd6cba8936a6553334ec8fdb1c84db8c50 (diff)
downloadaur-34854fc7fd6119e44064b9ef9152f308e5506525.tar.gz
update to new package format
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 18 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80c206174f89..ec58667f96ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,41 @@
# shellcheck disable=SC2034,SC2148,SC2154,SC2164
+
# Maintainer: Alessandro Cerruti
# Contributor: Alessandro Cerruti
_pkgbase=i3bard
pkgname=i3bard-git
-pkgver=r40.bcd373d
+pkgver=r51.6ac6be0
pkgrel=1
-pkgdesc='async i3blocks clone that can synchronize multiple instances'
+pkgdesc='async i3bar status_command generator that can synchronize multiple instances'
arch=('any')
url='https://gitlab.com/chrooti/i3bard'
license=('MIT')
depends=(python)
-makedepends=(git)
+makedepends=(
+ git
+ python-build
+ python-installer
+ python-setuptools
+ python-wheel
+)
source=('i3bard::git+https://gitlab.com/chrooti/i3bard.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgbase"
+ cd "${srcdir}/${_pkgbase}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "${srcdir}/${_pkgbase}"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/$_pkgbase"
+ cd "${srcdir}/${_pkgbase}"
- install -D -m 755 i3bard "$pkgdir"/usr/bin/i3bard
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -D -m 644 -t "$pkgdir"/usr/lib/i3bard/cmdlets cmdlets/*.py
install -D -m 644 i3bard.service "$pkgdir"/usr/lib/systemd/user/i3bard.service
install -D -m 644 i3bard.socket "$pkgdir"/usr/lib/systemd/user/i3bard.socket