summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormeskarune2016-03-27 11:02:46 -0400
committermeskarune2016-03-27 11:02:46 -0400
commitfc3d3eb666618757fde1be9dd79ca93c9bbeb560 (patch)
treec095f69f182d8e6e0128b8c2a5329e848bfd6d38 /PKGBUILD
downloadaur-fc3d3eb666618757fde1be9dd79ca93c9bbeb560.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..699fbe5d8560
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Dolores Portalatin <meskarune at gmail dot com>
+# Contributor: burntcookie90 <aur at vishnurajeevan dot com>
+_gitname=i3lock-fancy
+pkgname=i3lock-fancy-git
+pkgver=r46.c30b2a1
+pkgrel=1
+pkgdesc="i3lock-color script: blurs background, adds lock icon and text, offers dark/light background detection."
+arch=('i686' 'x86_64')
+url="https://github.com/meskarune/i3lock-fancy"
+license=('MIT')
+depends=('imagemagick' 'i3lock-color-git' 'scrot')
+makedepends=('git')
+provides=("i3lock-fancy")
+source=("git+https://github.com/meskarune/$_gitname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ patch -N ${srcdir}/${_gitname}/lock ../package.patch
+}
+package() {
+ cd "${srcdir}/$_gitname"
+ install -Dm755 lock ${pkgdir}/usr/bin/i3lock-fancy
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${_gitname}/LICENSE
+ install -Dm644 lock.png ${pkgdir}/usr/share/${_gitname}/lock.png
+ install -Dm644 lockdark.png ${pkgdir}/usr/share/${_gitname}/lockdark.png
+}