summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHarvey Hunt2015-10-03 14:23:29 +0100
committerHarvey Hunt2015-10-03 14:23:29 +0100
commite9acff7cda0902c8f0d5f2eea69ef394f6b7fbad (patch)
treeab1620aa254fdffd69a5712e1626941c379f04c9 /PKGBUILD
downloadaur-e9acff7cda0902c8f0d5f2eea69ef394f6b7fbad.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..538a2b8033b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Harvey Hunt <harveyhuntnexus at gmail dot com>
+# Contributor: Harvey Hunt
+
+pkgname=i3situation-git
+pkgrel=1
+pkgver="1.0.5.r0.g3538925"
+pkgdesc="A replacement for i3status written in Python 3 with support for huge customisability through plugins"
+url="https://github.com/harveyhunt/i3situation"
+arch=('any')
+license=('GPL3')
+conflicts=('i3situation')
+provides=('i3situation')
+depends=('python' 'python-setuptools')
+makedepends=('git')
+optdepends=('python-requests: For webscraping plugins')
+source=("git+https://github.com/harveyhunt/i3situation")
+md5sums=('SKIP')
+
+pkgver() {
+ cd i3situation
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd i3situation
+ python setup.py install --root="$pkgdir/" --optimize=1
+ # doc
+ install -d "$pkgdir"/usr/share/doc/$pkgname
+ install -m644 README.md "$pkgdir"/usr/share/doc/$pkgname
+ # license
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}