summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXilin Wu2022-09-26 15:04:39 +0800
committerXilin Wu2022-09-26 15:04:39 +0800
commit29c9f849e94e1cc39b679d423d3a7d76783da064 (patch)
tree2d5f03d09a8c28112f22b49c0f78f34207335d26 /PKGBUILD
downloadaur-29c9f849e94e1cc39b679d423d3a7d76783da064.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5875f1c5f4fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Xilin Wu <strongtz@yeah.net>
+
+_pkgbase=i915-sriov-dkms
+pkgname=i915-sriov-dkms-git
+pkgver=5.15.49
+pkgrel=1
+pkgdesc="Linux i915 module patched with SR-IOV support"
+arch=('x86_64')
+url="https://github.com/strongtz/i915-sriov-dkms"
+license=('GPL2')
+depends=('dkms')
+makedepends=('git')
+conflicts=("${_pkgbase}")
+install=${pkgname}.install
+source=("git+https://github.com/strongtz/i915-sriov-dkms.git")
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$_pkgbase"
+ # Copy dkms.conf
+ install -Dm644 dkms.conf "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+
+ echo "* Copying module into /usr/src..."
+ install -dm755 "${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
+ cp -r ${srcdir}/$_pkgbase/* "${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
+
+ # Set name and version
+ sed -e "s/@_PKGBASE@/${_pkgbase}/" \
+ -e "s/@PKGVER@/${pkgver}/" \
+ -i "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+
+ echo "* Blacklisting i915 module...(is this required?)"
+ install -D -m 644 modprobe.conf "${pkgdir}/etc/modprobe.d/i915-blacklist.conf"
+}