summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGaël PORTAY2023-09-30 05:32:01 +0200
committerGaël PORTAY2023-09-30 05:32:01 +0200
commit9161342de3e64f87dd6c577bf7523ac42231648b (patch)
treeaf07269782c5cea471768e53971d2bd1e69e3131 /PKGBUILD
parent19b0f93a612e4fd000d74c3ea30ff8a323895e48 (diff)
downloadaur-9161342de3e64f87dd6c577bf7523ac42231648b.tar.gz
iamroot-arm
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 15 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f4bf05e618d..7911c1c66c2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,43 @@
# Maintainer: Gaël PORTAY <gael.portay@gmail.com>
-pkgname=iamroot
+pkgname=iamroot-arm
pkgver=12
pkgrel=1
-pkgdesc='Emulating the syscall chroot(2) in an unpriviliged process'
+pkgdesc='Emulating the syscall chroot(2) in an unpriviliged process (arm)'
arch=('x86_64')
-url="https://github.com/gportay/$pkgname"
+url="https://github.com/gportay/${pkgname%-arm}"
license=('GPL')
-makedepends=('lib32-glibc'
- 'i386-musl'
- 'kernel-headers-musl-i386'
- 'musl'
- 'kernel-headers-musl'
+makedepends=('arm-musl'
+ 'arm-linux-gnueabi-gcc'
+ 'kernel-headers-musl-arm'
'git'
'asciidoctor')
checkdepends=('shellcheck')
options=('!strip')
-source=("https://github.com/gportay/$pkgname/archive/v$pkgver.tar.gz")
+source=("https://github.com/gportay/${pkgname%-arm}/archive/v$pkgver.tar.gz")
sha256sums=('8f17afcca200c309b88ed86cd6890fcba95ed83663b71dcca4ed6e2f54d749d7')
validpgpkeys=('8F3491E60E62695ED780AC672FA122CA0501CA71')
prepare() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname%-arm}-$pkgver"
ln -sf support/linux.mk makefile
touch local.mk
}
build() {
- cd "$pkgname-$pkgver"
- make i686/libiamroot-linux.so.2
- make i686/libiamroot-musl-i386.so.1
- make x86_64/libiamroot-linux-x86-64.so.2
- make x86_64/libiamroot-musl-x86_64.so.1
- make doc
+ cd "${pkgname%-arm}-$pkgver"
+ make CFLAGS= PREFIX=/usr arm/libiamroot-linux.so.3
+ make CFLAGS= PREFIX=/usr arm/libiamroot-musl-arm.so.1
}
check() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname%-arm}-$pkgver"
make -k check
}
package() {
- cd "$pkgname-$pkgver"
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec-i686-linux.2
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec-i686-musl-i386.1
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec-x86_64-linux-x86-64.2
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec-x86_64-musl-x86_64.1
- make PREFIX=/usr DESTDIR="$pkgdir" libiamroot.so
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec
- make PREFIX=/usr DESTDIR="$pkgdir" install-doc
- make PREFIX=/usr DESTDIR="$pkgdir" install-bash-completion
+ cd "${pkgname%-arm}-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install-exec-arm-linux.3
+ make PREFIX=/usr DESTDIR="$pkgdir" install-exec-arm-musl-arm.1
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}