summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGaël PORTAY2024-01-29 09:26:52 +0100
committerGaël PORTAY2024-01-29 09:26:52 +0100
commit51606a4f120f1d861f69f8b0fba30ec2cbe66223 (patch)
treef84ecc488ab0c30078667a833bcefa4e33a83a19 /PKGBUILD
parent40c19c53578a37a174c1843eb2a3b439d1c64ba1 (diff)
downloadaur-51606a4f120f1d861f69f8b0fba30ec2cbe66223.tar.gz
iamroot-s390x
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 11 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0457080a17da..08fc82637e42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,62 +1,40 @@
# Maintainer: Gaël PORTAY <gael.portay@gmail.com>
-pkgname=iamroot
+pkgname=iamroot-s390x
pkgver=16
pkgrel=1
-pkgdesc='Emulating the syscall chroot(2) in an unpriviliged process'
+pkgdesc='Emulating the syscall chroot(2) in an unpriviliged process (s390x)'
arch=('x86_64')
-url="https://github.com/gportay/$pkgname"
+url="https://github.com/gportay/${pkgname%-s390x}"
license=('GPL')
-makedepends=('lib32-glibc'
- 'i386-musl'
- 'kernel-headers-musl-i386'
- 'musl'
- 'kernel-headers-musl'
+makedepends=('s390x-z13-glibc-bleeding-edge-toolchain'
'git'
'patchelf'
'asciidoctor')
checkdepends=('shellcheck')
options=('!strip')
-source=("https://github.com/gportay/$pkgname/archive/v$pkgver.tar.gz")
+source=("https://github.com/gportay/${pkgname%-s390x}/archive/v$pkgver.tar.gz")
sha256sums=('72719b400b0588812fd1e62b4bada43372536d185b518ddaf24ef1e2c47b8ffb')
validpgpkeys=('8F3491E60E62695ED780AC672FA122CA0501CA71')
-# Fixes:
-#
-# $ ish
-# /bin/bash: symbol lookup error: /usr/lib/iamroot/libiamroot.so: undefined symbol: _Unwind_Resume
-CFLAGS="${CFLAGS//-fexceptions/}"
-export CFLAGS
-
prepare() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname%-s390x}-$pkgver"
ln -sf support/linux.mk makefile
touch local.mk
}
build() {
- cd "$pkgname-$pkgver"
- make PREFIX=/usr i686/libiamroot-linux.so.2
- make PREFIX=/usr i686/libiamroot-musl-i386.so.1
- make PREFIX=/usr x86_64/libiamroot-linux-x86-64.so.2
- make PREFIX=/usr x86_64/libiamroot-musl-x86_64.so.1
- make PREFIX=/usr doc
+ cd "${pkgname%-s390x}-$pkgver"
+ make CFLAGS= PREFIX=/usr s390x/libiamroot.so.1
}
check() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname%-s390x}-$pkgver"
make -k check
}
package() {
- cd "$pkgname-$pkgver"
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec-i686-linux.2
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec-i686-musl-i386.1
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec-x86_64-linux-x86-64.2
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec-x86_64-musl-x86_64.1
- make PREFIX=/usr DESTDIR="$pkgdir" libiamroot.so
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec
- make PREFIX=/usr DESTDIR="$pkgdir" install-doc
- make PREFIX=/usr DESTDIR="$pkgdir" install-bash-completion
+ cd "${pkgname%-s390x}-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install-exec-s390x.1
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}