summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTristan Rice2020-01-29 20:45:34 -0800
committerTristan Rice2020-01-29 20:45:34 -0800
commitca8cc7b64483b70db0cf265ca18ba96a89424983 (patch)
treeee95f44502ebe276d1688d63f50ce427c0368297 /PKGBUILD
downloadaur-ca8cc7b64483b70db0cf265ca18ba96a89424983.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..542bc01960db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+#Maintainer: Tristan Rice <rice at fn dot lc>
+
+_pkgname="iasimage"
+pkgname="${_pkgname}-git"
+pkgver=20190410.7799ac7
+pkgrel=1
+pkgdesc='iasimage is a utility program for creating Intel Automotive Service (IAS) images, a binary file format understood by bootloaders to load and initialize Operating Systems or Hypervisors.'
+url='https://github.com/intel/iasimage'
+arch=('i686' 'x86_64' 'armv7h')
+license=('custom:MIT')
+depends=('python-idna' 'python-wheel' 'python-cryptography')
+makedepends=('git')
+source=("${_pkgname}::git+https://github.com/intel/iasimage.git")
+sha1sums=('SKIP')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+pkgver() {
+cd "${srcdir}/${_pkgname}"
+git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+check() {
+cd "${srcdir}/${_pkgname}"
+make check
+}
+
+package() {
+cd "${srcdir}/${_pkgname}"
+install -Dm755 iasimage.py "${pkgdir}/usr/bin/iasimage"
+install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}