aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen Alex2015-11-30 13:16:06 +1100
committerBen Alex2015-11-30 13:16:06 +1100
commitf288b5f0b901442fe9efa2be4dc11b6181641e5d (patch)
tree3af676a91c2bbb445991779c75a9de08b806a815 /PKGBUILD
parent59960e232733f109d5b3d1b33faca72f39cc4b5f (diff)
downloadaur-f288b5f0b901442fe9efa2be4dc11b6181641e5d.tar.gz
Do not delete entire $HOME/Jts for normal package build, as this is
where TWS defaults its user setting storage. Deletion of $HOME/Jts retained in the tws_ scripts, as these are only run on the package maintainer's machine and the removal of the $HOME/Jts provides a more deterministic approach.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7bc302525ce5..571c408e7f8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,11 +28,11 @@ build() {
cd ${srcdir}
chmod +x tws-latest-standalone-linux-x64.sh
# Assumes no other Install4J packages are in use by user; if so, makepkg from dedicated user account
- rm -rf $HOME/.install4j $HOME/.i4j_jres $HOME/Jts
- ./tws-latest-standalone-linux-x64.sh -q
majorVer=$(echo "$pkgver" | sed "s/\([0-9]\+\)\..*/\1/")
+ rm -rf $HOME/.install4j $HOME/.i4j_jres $HOME/Jts/${majorVer}
+ ./tws-latest-standalone-linux-x64.sh -q
mv ${HOME}/Jts/${majorVer}/jars/*.jar ${srcdir}
- rm -rf $HOME/.install4j $HOME/.i4j_jres $HOME/Jts
+ rm -rf $HOME/.install4j $HOME/.i4j_jres $HOME/Jts/${majorVer}
cd ${srcdir}
# Thanks to http://finance.groups.yahoo.com/group/TWSAPI/files/RPM%20spec%20file/