summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHeiher2016-08-26 22:30:39 +0800
committerHeiher2016-08-26 22:30:39 +0800
commit261e2b95a03ca466b0f71b2d1268f3a0c6a64c94 (patch)
tree6025ca23cf6a8cfb11efc20d06567874c5d7102c /PKGBUILD
downloadaur-261e2b95a03ca466b0f71b2d1268f3a0c6a64c94.tar.gz
Update: 1.4.4-2.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..baa3f2c0340b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Heiher <r@hev.cc>
+
+pkgname=ibus-table-zhengma
+pkgver=1.4.4
+pkgrel=2
+pkgdesc="This is a ZhengMa table engine for IBus Table."
+arch=("any")
+url="http://code.google.com/p/ibus/"
+license=('GPL-3')
+depends=('ibus-table')
+source=("git+git://github.com/heiher/ibus-table-zhengma.git#tag=$pkgver")
+sha256sums=('SKIP')
+
+build()
+{
+ cd ${pkgname}
+
+ /usr/bin/ibus-table-createdb -n zhengma.db -s zhengma.txt
+}
+
+package()
+{
+ cd ${pkgname}
+
+ install -d ${pkgdir}/usr/share/ibus-table/icons/
+ install -d ${pkgdir}/usr/share/ibus-table/tables/
+ install -m0644 zhengma.svg ${pkgdir}/usr/share/ibus-table/icons/
+ install -m0644 zhengma.db ${pkgdir}/usr/share/ibus-table/tables/
+}