summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMoabeat2023-07-28 21:48:41 +0200
committerMoabeat2023-07-28 21:48:41 +0200
commit3b584aef28013806055250f4657f71e3ec1cb69e (patch)
treebc776a4ae66c04f52396642f2a1461d8900b1bd4 /PKGBUILD
parentd603455115bda37e8dc7266e57b5387748c7bfb4 (diff)
downloadaur-3b584aef28013806055250f4657f71e3ec1cb69e.tar.gz
Ensure $lang is not empty
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a024bfa2e683..5ee5fe3b4aac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -105,6 +105,7 @@ package() {
# wfica expects {module,wfclient,apssrv}.ini in $ICAROOT/config
# sadly these configs differ slightly by locale
lang=${LANG%%_*}
+ lang=${lang:-'en'}
[[ -d "${pkgdir}/$ICAROOT/nls/$lang" ]] || lang='en'
cp "${pkgdir}$ICAROOT/nls/$lang/module.ini" "${pkgdir}/$ICAROOT/config/"
cp "${pkgdir}$ICAROOT/nls/$lang/appsrv.template" "${pkgdir}/$ICAROOT/config/appsrv.ini"