summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorg Schlisio2015-11-11 12:59:45 +0100
committerGeorg Schlisio2015-11-11 12:59:45 +0100
commitbb230322864ebae8a3994e2ca1ab8618049bfbe7 (patch)
treeafebd805ed64f7d58aca9eee0e6a74ef02200c4c /PKGBUILD
parent34d1144acb9eed127c5ec2467ce4086dc76173df (diff)
downloadaur-bb230322864ebae8a3994e2ca1ab8618049bfbe7.tar.gz
added support for 32bit systems
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b7ea2b63f40f..777ffeae9ae8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Matthew Gyurgyik <matthew@pyther.net>
pkgname=icaclient
pkgver=13.2.1
-pkgrel=7
+pkgrel=8
pkgdesc="Citrix Receiver for x86_64 (64bit) Linux (ICAClient)"
-arch=('x86_64')
+arch=('x86_64' 'i686')
url="http://www.citrix.com/English/ps2/products/product.asp?contentID=1689163&ntref=prod_top"
license=('custom:Citrix')
depends=('alsa-lib' 'libvorbis' 'curl' 'gtk2' 'libpng12' 'libxml2' 'libxaw' 'libxext' 'libxft'
@@ -17,15 +17,24 @@ optdepends=(
conflicts=('bin32-citrix-client' 'citrix-client')
options=(!strip)
backup=("opt/Citrix/ICAClient/config/appsrv.ini" "opt/Citrix/ICAClient/config/wfclient.ini" "opt/Citrix/ICAClient/config/module.ini")
-source_url="http:$(curl -L -silent 'http://www.citrix.com/downloads/citrix-receiver/linux/receiver-for-linux-1321.html' | awk -F 'rel=\"' '/linuxx64-/ {print $2}'| awk -F'"' '{print $1}'| sed '/^$/d' |uniq)"
-source=('configmgr.desktop' 'conncenter.desktop' 'selfservice.desktop' 'wfica.desktop' 'wfica.sh' 'wfica_assoc.sh' $pkgname-$pkgver.tar.gz::$source_url)
-md5sums=('71aca6257f259996ac59729604f32978'
- 'a38c3f844a0fefe8017a25bee213b843'
- '0e92c33b3fcc99b04269787da2984809'
- '1f214f6f456f59afd1a3275580f4240e'
- '59f8e50cc0e0c399d47eb7ace1df5a32'
- 'dca5a1f51449ef35f1441b900d622276'
- 'd8f21201fae4a22605104f01ab9cf2da')
+source_url32="http:$(curl -L -silent 'http://www.citrix.com/downloads/citrix-receiver/linux/receiver-for-linux-1321.html' | awk -F 'rel=\"' '/linuxx86-/ {print $2}'| awk -F'"' '{print $1}'| sed '/^$/d' |uniq)"
+source_url64="http:$(curl -L -silent 'http://www.citrix.com/downloads/citrix-receiver/linux/receiver-for-linux-1321.html' | awk -F 'rel=\"' '/linuxx64-/ {print $2}'| awk -F'"' '{print $1}'| sed '/^$/d' |uniq)"
+source_i686=('configmgr.desktop' 'conncenter.desktop' 'selfservice.desktop' 'wfica.desktop' 'wfica.sh' 'wfica_assoc.sh' $pkgname-x86-$pkgver.tar.gz::$source_url32)
+source_x86_64=('configmgr.desktop' 'conncenter.desktop' 'selfservice.desktop' 'wfica.desktop' 'wfica.sh' 'wfica_assoc.sh' $pkgname-x64-$pkgver.tar.gz::$source_url64)
+md5sums_x86_64=('71aca6257f259996ac59729604f32978'
+ 'a38c3f844a0fefe8017a25bee213b843'
+ '0e92c33b3fcc99b04269787da2984809'
+ '1f214f6f456f59afd1a3275580f4240e'
+ '59f8e50cc0e0c399d47eb7ace1df5a32'
+ 'dca5a1f51449ef35f1441b900d622276'
+ 'd8f21201fae4a22605104f01ab9cf2da')
+md5sums_i686=('71aca6257f259996ac59729604f32978'
+ 'a38c3f844a0fefe8017a25bee213b843'
+ '0e92c33b3fcc99b04269787da2984809'
+ '1f214f6f456f59afd1a3275580f4240e'
+ '59f8e50cc0e0c399d47eb7ace1df5a32'
+ 'dca5a1f51449ef35f1441b900d622276'
+ 'bdd731b7c2c1d8b9546216def3ab9608')
install=citrix-client.install
package() {