summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKr1ss2021-07-12 22:17:04 +0200
committerKr1ss2021-07-12 22:17:04 +0200
commitb4dc3f772f097346a5cb4aaffc7a7f7da0bbae32 (patch)
tree3b68953fec218d4899c73dbbda402d0be2b8b044 /PKGBUILD
parentb973173d9733a19996ae6e765436658a28bfc786 (diff)
downloadaur-b4dc3f772f097346a5cb4aaffc7a7f7da0bbae32.tar.gz
update: ice-ssb-git 6.0.8.r30.5ddfc8e-2
Fix nonfunctional `Isolate` checkbox in configurations where Firefox is not installed. Hat tip @taconomix for the patch !
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad18331129a9..c37d3585987b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,9 @@
_name=ice
pkgname=ice-ssb-git
-pkgver() {
- git -C "$_name" describe --tags | sed 's/v\?\([^-]\+\)-/\1.r/;s/-g/./'
-}
+pkgver() { git -C "$_name" describe --tags | sed 's/v\?\([^-]\+\)-/\1.r/;s/-g/./'; }
pkgver=6.0.8.r30.5ddfc8e
-pkgrel=1
+pkgrel=2
pkgdesc='Desktop integration for webapps'
url="https://github.com/peppermintos/$_name"
@@ -24,22 +22,21 @@ optdepends=('brave' 'firefox' 'chromium' 'google-chrome' 'vivaldi')
source=("git+$url.git" "$_name.patch")
sha256sums=('SKIP'
- '1b3ba9c290faa8a9f2c8caf6c754378ac7ae82cf1117318a115e075b800c10d3')
+ 'f5c36986ee2f96860108ae3537fdf9ebb41c4478aa13a9fe3578b18ebd518eb4')
prepare() {
- cd "$_name"
- # patch browser binary filenames to match Archlinux packages
- patch --verbose -Np1 <"../$_name.patch"
- # delete PeppermintOS specific assets
- rm -r usr/lib
+ cd "$_name"
+ patch --verbose -Np1 <"../$_name.patch"
+ # delete PeppermintOS specific assets
+ rm -r usr/lib
}
package() {
- cd "$_name"
- cp -a --no-preserve=o usr "$pkgdir/"
- install -Dm644 README.md -t"$pkgdir/usr/share/doc/$_name/"
+ cd "$_name"
+ cp -a --no-preserve=o usr "$pkgdir/"
+ install -Dm644 README.md -t"$pkgdir/usr/share/doc/$_name/"
}
-# vim: ts=4 sw=4 et ft=PKGBUILD:
+# vim: ts=2 sw=2 et ft=PKGBUILD: