summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Figueras2015-10-15 00:31:01 +0200
committerJoan Figueras2015-10-15 00:31:01 +0200
commit87a1af2e8e54340b495a88497b3b04023db0851e (patch)
tree052b2212052ee5d96f4825df411696818f94af32 /PKGBUILD
parentf840b90c4ad562c722df954896d913fac310f304 (diff)
downloadaur-87a1af2e8e54340b495a88497b3b04023db0851e.tar.gz
Removed ssp-buffer-size from make flags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90b68898bda3..c4c577a96075 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,14 +27,14 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
install=icecat.install
source=(https://ftp.gnu.org/gnu/gnuzilla/${pkgver}/${pkgname}-${_pkgver}.tar.bz2{,.sig}
-#source=(https://mirrors.kernel.org/gnu/gnuzilla/${pkgver}/${pkgname}-${_pkgver}.tar.bz2 ## Good mirror
-#source=(http://jenkins.trisquel.info/icecat/${pkgname}-${_pkgver}.tar.bz2 ## Official developer (Ruben Rodriguez) site
- mozconfig
+#source=(https://mirrors.kernel.org/gnu/gnuzilla/${pkgver}/${pkgname}-${_pkgver}.tar.bz2{,.sig} ## Good mirror
+#source=(http://jenkins.trisquel.info/icecat/${pkgname}-${_pkgver}.tar.bz2{,.sig} ## Official developer (Ruben Rodriguez) site. Be careful, can contain testing builds.
+ mozconfig
icecat.desktop
icecat-safe.desktop
vendor.js
freetype26.patch
- 0001-Bug-1194520-Add-a-system-header-wrapper-for-freetype.patch)
+ 0001-Bug-1194520-Add-a-system-header-wrapper-for-freetype.patch)
sha256sums=('08fe9724a84aef2182265b230c68fa37a36a5d93ffd5118ec0739718dc71a66e'
'SKIP'
@@ -80,10 +80,10 @@ build() {
# Default Arch flags
if [ "${CARCH}" = 'x86_64' ]; then
- export CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4"
+ export CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong"
export CXXFLAGS="$CFLAGS"
elif [ "${CARCH}" = 'i686' ]; then
- export CFLAGS="-march=i686 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4"
+ export CFLAGS="-march=i686 -mtune=generic -O2 -pipe -fstack-protector-strong"
export CXXFLAGS="$CFLAGS"
fi