summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViachaslau Khalikin2019-10-27 17:40:48 +0300
committerViachaslau Khalikin2019-10-27 17:40:48 +0300
commitf52deec2e38ae08c7c493f077071d7e574c21add (patch)
treef34069969b2d775dd56a3689f4bdc4271a29b0a0 /PKGBUILD
downloadaur-f52deec2e38ae08c7c493f077071d7e574c21add.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f323cd8eaca6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Viachaslau Khalikin <khalikin'at'yandex'dot'by>
+
+pkgname=icecat-umatrix
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='Point and click matrix to filter net requests by source, destination and type'
+url=https://github.com/gorhill/uMatrix
+arch=('any')
+license=('GPL3')
+groups=('icecat-addons')
+source=("https://github.com/gorhill/uMatrix/releases/download/${pkgver}/uMatrix.firefox.xpi")
+noextract=("${source##*/}")
+sha256sums=('8e00959b70ba6d676a63022594d4414ce6ea3a9d13bc3099f25d282a275fb160')
+
+package() {
+ install -Dm644 "${source##*/}" "$pkgdir"/usr/lib/icecat/browser/extensions/uMatrix@raymondhill.net.xpi
+}
+
+# vim:set ts=2 sw=2 et: