summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp Fent2019-02-12 10:25:44 +0100
committerPhilipp Fent2019-02-12 10:25:44 +0100
commitbaf78ddcc55c746219dbdbe7aedaafd6a29ef720 (patch)
treec50b40c128b1a30395fdb854a9d79116266c5100 /PKGBUILD
parent571c31c8324b8d1526b2856dd4147b31a9dfec46 (diff)
downloadaur-baf78ddcc55c746219dbdbe7aedaafd6a29ef720.tar.gz
initial import from icecream package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29274267fb2b..71cc74773c88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
-# Maintainer: Ben Widawsky <ben@bwidawsk.net>
+# Maintainer: Philipp Fent <philipp@fent.de>
+# Contributor: Ben Widawsky <ben@bwidawsk.net> (icecream package)
# Contributor: Isaac C. Aronson <isaac@pingas.org> (original PKGBUILD)
# Contributor: Sergio Correia <sergio@correia.cc> (modifications derived from icecream-git package)
-pkgname=icecream
-pkgver=1.2
+_pkgname=icecream
+pkgname=icecream-git
+pkgver=r1959.e39103f
pkgrel=1
pkgdesc="takes compile jobs from your build and distributes it to remote machines allowing a parallel build on several machines."
url="http://en.opensuse.org/Icecream"
@@ -13,26 +15,33 @@ depends=('bash' 'libcap-ng' 'lzo')
provides=('icecream')
optdepends=('iceberg-git: A Qt based monitor for icecream nodes'
'ccache: ccache enabled remote builds.')
-conflicts=('icecream-git')
+conflicts=('icecream')
backup=('etc/icecream.conf')
arch=('x86_64')
install=icecream.install
-source=("https://github.com/icecc/$pkgname/archive/$pkgver.tar.gz"
+source=('git+https://github.com/icecc/icecream.git'
icecream.conf
icecream.service
icecream-scheduler.service
icecreamd
icecream-schedulerd
ld-icecream.conf)
-sha256sums=('12d4132e5aacf6907877b691a8ac09e3e2f704ca016c49bc5eb566fc9185f544'
+sha256sums=('SKIP'
'4c1b993761600955a2be53e945a698638ef861a513258956d8aac0e0f8df3dfe'
'3bd9286e2a4ef29a41fe414caf3ffb56ae24e2287272dc0d60d62599d20d8cf9'
'9b756a140ac3983efa4cddf6590af72d3681834b95ef1f879f34da775dd418cd'
'cdb7794bf53486eb46716e57172c58cd4cb97b7649cd98178f0eefe03444a88a'
'c6807f49ac0e191136047d22d01639b04fad9b009d829528dafe02665712eb0f'
'2221f16c3293dfd86e4d0442745b104380a4a1623ca3c9eb6bfe5771552fac65')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/${_pkgname}"
./autogen.sh
./configure --prefix=/usr/lib/icecream --enable-shared --disable-static --without-man
@@ -40,7 +49,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/${_pkgname}"
make DESTDIR="$pkgdir" install
install -D -m755 "$srcdir"/icecream.conf "$pkgdir/etc/icecream.conf"