summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2017-02-14 00:43:29 +0200
committerAdrian Perez de Castro2017-02-14 00:43:29 +0200
commit0523a16768edd2c353739c72ceab2ac2e6574819 (patch)
tree54aa92fc0193249e8a5370f7f11b91ea77623df3 /PKGBUILD
parentd6ed5d7b49079c50b1663f390373adb0a7d49f1e (diff)
downloadaur-0523a16768edd2c353739c72ceab2ac2e6574819.tar.gz
Switch over to the Meson build system
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e47b1b261b5c..f074c3fbf87b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
pkgdesc='Terminal top-like monitor for icecream/icecc'
pkgname='icetop-git'
-pkgver=r25.8f2a355
+pkgver=r37.48482f3
pkgrel=1
license=('GPL2')
arch=('x86_64' 'i686')
depends=('icecream' 'libdill' 'libtickit-bzr')
-makedepends=('autoconf')
+makedepends=('meson' 'ninja')
url='https://github.com/aperezdc/icetop'
source=("${pkgname}::git+${url}")
sha512sums=("SKIP")
@@ -20,18 +20,13 @@ pkgver () {
)
}
-prepare () {
- cd "${pkgname}"
- autoreconf -i -v
-}
-
build () {
cd "${pkgname}"
- ./configure --prefix=/usr
- make
+ meson --buildtype release --prefix /usr build
+ ninja -C build
}
package () {
cd "${pkgname}"
- make install DESTDIR="${pkgdir}"
+ DESTDIR="${pkgdir}" ninja -C build install
}