summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2013-10-10 11:59:26 -0600
committerBrian Bidulock2015-06-10 06:13:34 -0600
commit3fe060775feae709f407fb0f9a249629236670e3 (patch)
tree4ae466c3ba1a81fdc64ee2d6e433b3a0848b263b /PKGBUILD
parentb8263d35b592fecf52b0f802531433a1137aaddd (diff)
downloadaur-3fe060775feae709f407fb0f9a249629236670e3.tar.gz
version 1.3.8-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 25 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4918f3c13214..14575b3d967c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,46 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=icewm-git
-pkgver=1.3.9.104
+pkgver=1.3.8
pkgrel=1
pkgdesc="A window manager designed for speed, usability, and consistency"
arch=('i686' 'x86_64')
-url="https://github.com/bbidulock/icewm"
+url="http://icewm.org/"
license=('LGPL')
-provides=('icewm' 'icewm2')
-conflicts=('icewm' 'icewm2' 'icwm-cvs' 'icwm-ak' 'icwm-init0' 'icwm-testing' 'icwm-zstegi')
-depends=('libxft' 'libxinerama' 'gdk-pixbuf2' 'libxrandr' 'libsndfile' 'libsm' 'fribidi')
+provides=('icewm')
+conflicts=('icewm' 'icwm-cvs' 'icwm-ak' 'icwm-init0' 'icwm-testing' 'icwm-zstegi')
+depends=('libxft' 'libxinerama' 'gdk-pixbuf2')
makedepends=('git' 'xorg-mkfontdir' 'linuxdoc-tools')
-source=("$pkgname::git+https://github.com/bbidulock/icewm.git")
+source=('git://github.com/bbidulock/icewm.git')
md5sums=('SKIP')
pkgver() {
- cd $pkgname
- git describe --tags --always | sed 's|^[^0-9]*||;s|[-_]|.|g;s|[.]g[a-f0-9]*$||'
+ cd icewm
+ git describe --tags --always | sed 's|icewm_||;s|[-_]|.|g;s|[.]g[a-f0-9]*$||'
+}
+
+prepare() {
+ cd icewm
+ sed -i VERSION \
+ -e 's/^VERSION=.*$/VERSION='"$pkgver"'/'
+ sed <icewm.spec.in >icewm.spec \
+ -e 's/%%VERSION%%/'"$pkgver"'/'
+ sed <icewm.lsm.in >icewm.lsm \
+ -e 's/%%VERSION%%/'"$pkgver"'/' \
+ -e 's/%%DATE%%/'"`date +%d%b%Y`"'/'
}
build() {
- cd $pkgname
- ./autogen.sh
+ cd icewm
+ autoreconf -fiv
./configure --prefix=/usr --sysconfdir=/etc \
- --enable-shaped-decorations --enable-gradients \
- --enable-guievents --with-icesound=ALSA,OSS \
- --disable-menus-gnome2 \
- EXTRA_LIBS="/usr/lib/libsupc++.a"
- make V=0
+ --enable-shaped-decorations --enable-gradients
+ make all docs nls
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir" install
+ cd icewm
+ make DESTDIR="$pkgdir" install install-man install-docs install-nls install-desktop
}
# vim: sw=2 et: